3dTools MediaElement problem

Topics: User Forum
May 1, 2007 at 11:31 PM
Hi there,

i was trying to create a WPF application similar to the one over http://contentpresenter.com about 3dTools..
i actually almost did copy & paste the code but something seems to be missing because i can hear the video playing but i cannot see it !!

it seemed like i have something over it so i used the same values in the tutorial but in vain..
i pasted the code below for reviewing:

<Window
xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
xmlns:local="clr-namespace:UntitledProject1"
xmlns:inter3D="clr-namespace:_3DTools;assembly=3DTools"
x:Class="UntitledProject1.Window1"
x:Name="Window"
Title="Window1"
Width="320" Height="240">

<Window.Resources>
<MeshGeometry3D x:Key="planeMesh" Positions = " -1, -1, 0
-1, 1, 0
1, 1, 0
1, -1, 0"
TextureCoordinates =" 0,1 1,1 1,0 0,0"
TriangleIndices =" 0 1 2 0 2 3"/>
</Window.Resources>

<Grid x:Name="LayoutRoot" Background="Black">
<inter3D:TrackballDecorator>
<inter3D:Interactive3DDecorator>
<Viewport3D>

<Viewport3D.Camera>
<PerspectiveCamera Position="0, 0, 1000" LookDirection="0, 0, -1"/>
</Viewport3D.Camera>

<ModelVisual3D>
<ModelVisual3D.Content>
<AmbientLight />
</ModelVisual3D.Content>
</ModelVisual3D>


<inter3D:InteractiveVisual3D Geometry = "{StaticResource planeMesh}">
<inter3D:InteractiveVisual3D.Visual>

<MediaElement Width="200" Height="200"
Source="C:\Users\Bassem\Desktop\Audio FingerPrint\WPF\contentpresenter_3DTools.wmv"/>
</inter3D:InteractiveVisual3D.Visual>
</inter3D:InteractiveVisual3D>


</Viewport3D>
</inter3D:Interactive3DDecorator>
</inter3D:TrackballDecorator>

</Grid>
</Window>

Thanks in advance