Invalid XAML in MS Expression Blend

Topics: User Forum
Mar 1, 2007 at 2:47 PM
First: Thanks for the great ressources!

I just downloaded the 3D tools sourcecode. Unfortunately by opening the csproj-files in Blend I get the error 'Invalid XAML' with lots of problem messages like 'The name "Window" does not exist in the namespace "http://schemas.microsoft.com/winfx/2006/xaml/presentation"' etc.

Also, under "Project" most of the references are marked with a yellow "!". I guess there's a correlation?
Does anybody know how to fix this problem?

P.S.: If possible, please take in account that I'm a designer and not a developer. ;-)
Mar 13, 2007 at 2:20 PM
Edited Mar 13, 2007 at 2:20 PM
I could work around the problem by creating a new project and copying the relevant code. This is described here in more detail: http://www.microsoft.com/communities/newsgroups/en-us/default.aspx?dg=microsoft.public.expression.interactivedesigner&tid=a7aabcee-e7ca-4911-8033-51829fb06c7f&cat=&lang=en&cr=US&p=7
Coordinator
Mar 20, 2007 at 6:17 PM
I played around a bit with this myself, and I think the problem with opening an individual csproj file in Blend is that it can't find the 3DTools reference. If you open the solution itself in blend though, everything is ok, since now it knows the rule on how to get the 3DTools dll. If you just want to open an individual csproj file, you can copy the 3DTools.dll file (from either the bin download, or by building it yourself from the source) in to the directory with the csproj file, and then add it as a reference in your Blend project. Then I think the references should be resolved.